Actions

User talk

Kghbln

From WikiApiary, monitoring the MediaWiki universe

Revision as of 19:50, 20 September 2018 by Dinoguy1000 (talk | contribs) ("Cannot set URL automatically because multiple URLs were found": note)

Archived talk: 01 - 02 - 03 - 04 | r | f | smw | -u-a / -u+a / +u-a / bl (e) | sm / Curated wikis: 1201 of 29113 (4.13 %)

https://wikiapiary.com/w/index.php?title=User_talk:Kghbln&action=edit

Javascript errors

Has anyone been working on resolving the Javascript errors that are keeping such things as menu dropdowns from working? It seems also that pages for sites haven't been working correctly for a while now, and I'm wondering how much of that is also due to the JS errors. ディノ千?!? · ☎ Dinoguy1000 07:58, 27 August 2018 (UTC)

I guess the issue is that Foreground is no longer compatible with the version of MediaWiki used here. There is another instance to overcome this issue however, I need to adapt the look and feel better and change some templates. I am pretty tight in time at the moment. Cheers --[[kgh]] (talk) 14:15, 27 August 2018 (UTC)
Aah, makes sense. ディノ千?!? · ☎ Dinoguy1000 16:23, 27 August 2018 (UTC)

I want to change skin

hello, Kghbln, i want to change skin. from the default skin called foreground, to vector. first, does not the "nav-menus" in the foreground skin work, and every time i need to read a page here must I add ?useskin=vector to the url to use the vector skin instead of the foreground, and i want to select the vector skin in preferences and currently is only the foreground available and I want to have the vector skin available, and please can you add so vector skin can be chosen in the preferences/options in the localsettings.php? -Psl631 (talk) 11:51, 7 September 2018 (UTC)

I am not sure if you read my last reply to you. Cheers --[[kgh]] (talk) 12:22, 7 September 2018 (UTC)
Yes, i read it, also there appear no edit toolbar while i editing now, even if i have the show edi toolbar checkbox ticked --Psl631 (talk) 13:34, 7 September 2018 (UTC)

"Cannot set URL automatically because multiple URLs were found"

Replacing the code in Template:Extension in use with the following code will (should) fix this message for all extensions with a MediaWiki.org URL (and thus a major source of annoyance for me for some time now) (changed/added code in blue):

<noinclude> {{/doc}} </noinclude><includeonly>{{#if: {{{Extension name|}}} | {{ #if: {{#var: MediaWiki_Version}} <!-- we stash MediaWiki version into an array so that we don't need to determine it n times for each instance of this template on a Web site --> | <!-- version is defined, we don't need to do anything --> | <!-- get the version -->{{#vardefine: MediaWiki_Version | {{#show: {{ROOTPAGENAME}} | ?Has MediaWiki version}} }} }}{{ #if: {{#var: Current_farm_set}} <!-- we stash current farm into a variable to avoid n lookups --> | <!-- Current_farm is defined, we don't need to do anything --> | <!-- get the Current_farm -->{{#vardefine: Current_farm | {{#show: {{ROOTPAGENAME}} | ?Has farm | link=none}} }}{{#vardefine: Current_farm_set | 1}} }}{{ #vardefine: Extension_URL | {{{Extension URL|{{{URL Embedded in name|}}}}}} }}{{ #if: {{#var: Extension_URL}} | {{ #if: {{#pos: {{#var: Extension_URL}} | mediawiki.org}} | {{#vardefine: Extension_URL | {{#replace: {{#var: Extension_URL}} | http: | https: }} }} }} }}{{#subobject:Extension {{{Extension name}}} |Has website={{ROOTPAGENAME}} |Has MediaWiki version={{#var: MediaWiki_Version}} |Has farm={{#var: Current_farm}} |Has extension=Extension:{{{Extension name}}} |Has extension version={{{Extension version|Unknown}}} |Has extension type={{{Extension type|}}} |Has extension URL={{#var: Extension_URL}} |Has extension vcs version={{{vcs-version|}}} |Has extension vcs system={{{vcs-system|}}} |Has extension vcs date={{{vcs-date|}}} |Has extension vcs URL={{{vcs-url|}}} |Has extension license name={{{license-name|}}} |Has remote error={{{Remote error|}}} }}{{#if: {{{Extension author|}}} | {{#arraymap: {{{Extension author}}} | , | @@@@ | {{#subobject:Extension {{{Extension name}}} | Has author=@@@@ }} | }} }}}}</includeonly>

Note that I have only convinced myself that this code is correct, not actually run it, so I would encourage you to preview before saving to make sure I didn't overlook some glaring syntax error. =D

This code can be trivially extended to normalize any other sites which have both HTTP and HTTPS URLs being stored, just by adding a #pos statement for each.

While I have your ear, would there be a problem with assigning me the editor usergroup? I don't edit here very often, granted, but having this would allow me to make fixes of this nature to editor-protected templates in the future without having to go through you to do so. ディノ千?!? · ☎ Dinoguy1000 23:48, 20 September 2018 (UTC)